<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Five Pound Snap premiere new song “Lady Gets High”</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://www.ecurrent.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://www.ecurrent.com/wp-content/themes/ecurrent/js/html5.js"></script>
    <script src="http://www.ecurrent.com/wp-content/themes/ecurrent/js/html5shiv.min.js"></script>
    <script src="http://www.ecurrent.com/wp-content/themes/ecurrent/js/respond.min.js"></script>
	<![endif]-->
	        <style type="text/css" id="dynamic-style">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</style>
        
<!-- All in One SEO Pack 2.3.8 by Michael Torbert of Semper Fi Web Design[297,373] -->
<meta name="description" itemprop="description" content="Five Pound Snap are a four-piece out of Detroit that blend the grit, sweat, and spilled-out strummers of keyed-up rock ‘n’ roll with smoothness of jazz and the" />

<link rel="canonical" href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/" />
<!-- /all in one seo pack -->
<link rel="alternate" type="application/rss+xml" title="Current Magazine &raquo; Feed" href="http://www.ecurrent.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Current Magazine &raquo; Comments Feed" href="http://www.ecurrent.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Current Magazine &raquo; Five Pound Snap premiere new song “Lady Gets High” Comments Feed" href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.ecurrent.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.5.2"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='foobox-free-min-css'  href='http://www.ecurrent.com/wp-content/plugins/foobox-image-lightbox/free/css/foobox.free.min.css?ver=1.1.11' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-open-sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans:400,700' type='text/css' media='all' />
<link rel='stylesheet' id='et_monarch-css-css'  href='http://www.ecurrent.com/wp-content/plugins/monarch/css/style.css?ver=1.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='http://www.ecurrent.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://www.ecurrent.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='ecurrent-style-css'  href='http://www.ecurrent.com/wp-content/themes/ecurrent/style.css?ver=4.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='template-google-font-css'  href='//fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='ecurrent-bootstrap-css-css'  href='http://www.ecurrent.com/wp-content/themes/ecurrent/css/bootstrap.min.css?ver=4.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='ecurrent-bootstrap-css-theme-css'  href='http://www.ecurrent.com/wp-content/themes/ecurrent/css/bootstrap-theme.css?ver=4.5.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.ecurrent.com/wp-includes/js/jquery/jquery.js?ver=1.12.3'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery-ui.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/plugins/foobox-image-lightbox/free/js/foobox.free.min.js?ver=1.1.11'></script>
<link rel='https://api.w.org/' href='http://www.ecurrent.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.ecurrent.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.ecurrent.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Checking in with: King Milo and Louis Picasso' href='http://www.ecurrent.com/music/checking-in-with-king-milo-and-louis-picasso/' />
<link rel='next' title='U.S. Education Secretary Betsy DeVos Advocates Return to Agrarian Society; Rich People Not Worried' href='http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/' />
<link rel='shortlink' href='http://www.ecurrent.com/?p=25547' />
<link rel="alternate" type="application/json+oembed" href="http://www.ecurrent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ecurrent.com%2Fmusic%2Ffive-pound-snap-premiere-new-song-lady-gets-high%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.ecurrent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ecurrent.com%2Fmusic%2Ffive-pound-snap-premiere-new-song-lady-gets-high%2F&#038;format=xml" />
<script type='text/javascript' data-cfasync='false'>var _mmunch = {'front': false, 'page': false, 'post': false, 'category': false, 'author': false, 'search': false, 'attachment': false, 'tag': false};_mmunch['post'] = true; _mmunch['postData'] = {"ID":25547,"post_name":"five-pound-snap-premiere-new-song-lady-gets-high","post_title":"Five Pound Snap premiere new song \u201cLady Gets High\u201d","post_type":"post","post_author":"20","post_status":"publish"}; _mmunch['postCategories'] = [{"term_id":1,"name":"Music","slug":"music","term_group":0,"term_taxonomy_id":1,"taxonomy":"category","description":"","parent":0,"count":524,"filter":"raw","object_id":25547,"cat_ID":1,"category_count":524,"category_description":"","cat_name":"Music","category_nicename":"music","category_parent":0}]; _mmunch['postTags'] = [{"term_id":5,"name":"Music","slug":"music","term_group":0,"term_taxonomy_id":5,"taxonomy":"post_tag","description":"","parent":0,"count":523,"filter":"raw","object_id":25547},{"term_id":372,"name":"music - wwup","slug":"music-wwup","term_group":0,"term_taxonomy_id":372,"taxonomy":"post_tag","description":"","parent":0,"count":21,"filter":"raw","object_id":25547},{"term_id":29,"name":"Online","slug":"online","term_group":0,"term_taxonomy_id":29,"taxonomy":"post_tag","description":"","parent":0,"count":356,"filter":"raw","object_id":25547}]; _mmunch['postAuthor'] = {"name":"","ID":""};</script><script data-cfasync="false" src="//a.mailmunch.co/app/v1/site.js" id="mailmunch-script" data-plugin="cc_mm" data-mailmunch-site-id="299994" async></script><style type="text/css" id="et-social-custom-css">
				 
			</style>        <script type="text/javascript">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</script>
        <meta property="og:title" content="  Five Pound Snap premiere new song “Lady Gets High”Current Magazine"/><meta property="og:description" content="Five Pound Snap are a four-piece out of Detroit that blend the grit, sweat, and spilled-out strummers of keyed-up rock ‘n’ roll with smoothness of jazz and the attitude of funk."/><meta property="og:url" content="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/"/><meta property="og:type" content="article"/><meta property="og:image" content="http://www.ecurrent.com/wp-content/uploads/2017/02/five-pound-snap-pic-by-megan-lacroix.jpg"/><link rel="icon" href="http://www.ecurrent.com/wp-content/uploads/2016/09/cropped-cur-favicon-32x32.png" sizes="32x32" />
<link rel="icon" href="http://www.ecurrent.com/wp-content/uploads/2016/09/cropped-cur-favicon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.ecurrent.com/wp-content/uploads/2016/09/cropped-cur-favicon-180x180.png" />
<meta name="msapplication-TileImage" content="http://www.ecurrent.com/wp-content/uploads/2016/09/cropped-cur-favicon-270x270.png" />
		
	
	<!-- Generated by Revive Adserver v3.1.0 -->
<script type='text/javascript' src='http://mlivingnews.com/revive/www/delivery/spcjs.php?id=5'></script>

 <!-- Google -->
 <script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-44849710-5', 'auto');
  ga('send', 'pageview');

</script>

 
<script type="text/javascript">
    adroll_adv_id = "M54USCANPZAFRKBQTAHDG6";
    adroll_pix_id = "YJOZJABQXBDBFMEZMQQ3RU";
    /* OPTIONAL: provide email to improve user identification */
    /* adroll_email = "username@example.com"; */
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>

    
	
</head>

<body class="single single-post postid-25547 single-format-standard et_monarch group-blog singular">


<div id="page" class="hfeed site">
    <div class="container" style="display: block;">
    <div class="stick-container container"><div class="row">
        <div class="stick-wrap">
            <div class="col-md-2 leaderboard-side left-leaderboard">
                            <div class="leaderboard-mobile mobile-ads">
                                                            <a href="" target="_blank"></a>
                                                    
                </div>
                <div class="leaderboard-desktop">
                    <script type='text/javascript'><!--// <![CDATA[
    /* [id22] Current - 160x600 - Left */
    OA_show(22);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=99b2bec'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=22&amp;n=99b2bec' /></a></noscript>                </div>
                        </div>
            <div class="col-md-8 ecurrent-wrap"></div>
            <div class="col-md-2 leaderboard-side right-leaderboard">
                            <div class="leaderboard-mobile mobile-ads">
                                                            <a href="" target="_blank"></a>
                                                    
                </div>
                <div class="leaderboard-desktop">
                <script type='text/javascript'><!--// <![CDATA[
    /* [id21] Current - 160x600 - Right */
    OA_show(21);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=137839b'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=21&amp;n=137839b' /></a></noscript>                </div>
                        </div>
        </div>
    </div></div>
</div>
<div class="container glutter-stick"><div class="row">
<div class="col-md-2 leaderboard-side left-leaderboard"><div class="leaderboard-ads">

<script type='text/javascript'><!--// <![CDATA[
    /* [id22] Current - 160x600 - Left */
    OA_show(22);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=99b2bec'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=22&amp;n=99b2bec' /></a></noscript></div><!--.leaderboard-ads--></div><!--.leaderboard-side--><div class="col-md-8 ecurrent-wrap">

    <div class="row header-top">
        <div class="col-md-3 topmenucontainer"><div class="top-menu">
        <div class="row"><div class="col-xs-6 col-md-12">
             <a href="http://www.ecurrent.com/advertise/" class="top-nav">Advertise</a>
             <a href="http://www.ecurrent.com/contact/" class="top-nav">Contact</a>
             <a href="" class="top-nav"></a>
                    </div><div class="col-xs-6 col-md-12 social-network">
            <div class="social-network">
                 <a href="https://www.instagram.com/current_mag/" target="_blank" class="sosmed"><img width="18" height="18" src="http://www.ecurrent.com/wp-content/uploads/2016/05/instagram.png" class="attachment-full size-full" alt="instagram" /></a>
                 <a href="https://www.facebook.com/currentmagazine/" target="_blank" class="sosmed"><img width="9" height="18" src="http://www.ecurrent.com/wp-content/uploads/2016/05/facebook.png" class="attachment-full size-full" alt="facebook" /></a>
                 <a href="https://twitter.com/ecurrent" target="_blank" class="sosmed"><img width="19" height="17" src="http://www.ecurrent.com/wp-content/uploads/2016/05/twitter.png" class="attachment-full size-full" alt="twitter" /></a>
                            </div>
        </div> </div>
        </div></div><!--.topmenucontainer-->
        <div class="col-md-6"><div class="navbar-header">
          <a class="navbar-brand" href="http://www.ecurrent.com/" rel="home"><img width="313" height="83" src="http://www.ecurrent.com/wp-content/uploads/2016/05/current-logo-big.png" class="attachment-full size-full" alt="current-logo-big" srcset="http://www.ecurrent.com/wp-content/uploads/2016/05/current-logo-big.png 313w, http://www.ecurrent.com/wp-content/uploads/2016/05/current-logo-big-300x80.png 300w" sizes="(max-width: 313px) 100vw, 313px" /></a>
        </div> <!--.navbar-header--></div> 
        <div class="col-md-3 sosmedcontainer">
        <div class="row">
            <div class="col-xs-12 mobile-button">
                <a class="navbar-brand" href="http://www.ecurrent.com/" rel="home"><img width="138" height="30" src="http://www.ecurrent.com/wp-content/uploads/2016/05/current-small-white.png" class="attachment-full size-full" alt="current-small-white" /></a>
                <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false">
                <span class="sr-only">Toggle navigation</span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
                <span class="icon-bar"></span>
              </button>
            </div>
            <div class="social-network col-md-12">
                 <a href="https://www.instagram.com/current_mag/" target="_blank" class="sosmed"><img width="18" height="18" src="http://www.ecurrent.com/wp-content/uploads/2016/05/instagram.png" class="attachment-full size-full" alt="instagram" /></a>
                 <a href="https://www.facebook.com/currentmagazine/" target="_blank" class="sosmed"><img width="9" height="18" src="http://www.ecurrent.com/wp-content/uploads/2016/05/facebook.png" class="attachment-full size-full" alt="facebook" /></a>
                 <a href="https://twitter.com/ecurrent" target="_blank" class="sosmed"><img width="19" height="17" src="http://www.ecurrent.com/wp-content/uploads/2016/05/twitter.png" class="attachment-full size-full" alt="twitter" /></a>
                            </div>
        </div>
        <div class="row">
            <div class="mobile-navbar">
                <div id="navbar" class="yamm navbar-default collapse navbar-collapse"><nav id="mobile-main-nav" role="navigation"><ul id="mobile-mainmenu" class="menu nav navbar-nav sm sm-collapsible">                    <li class="mobile-nav-item ">
                        <a href="http://www.ecurrent.com/news/" class="has-submenu">News<span class="caret"></span></a>
                                                <ul class="submenu-wrap sub-1 dropdown-menu">
                                                            <li><div class="row module-menu<br />
<b>Warning</b>:  in_array() expects parameter 2 to be array, string given in <b>/home/ecurrent/public_html/wp-content/themes/ecurrent/inc/infostream-conf.php</b> on line <b>1683</b><br />
"><div class="col-md-12 col-sm-12 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/news/" >The Latest</a></li><li><a href="http://www.ecurrent.com/news/business/" >Business</a></li><li><a href="http://www.ecurrent.com/news/environment/" >Enviroment</a></li><li><a href="http://www.ecurrent.com/news/cannabis/" >Cannabis</a></li><li><a href="http://www.ecurrent.com/news/locals/" >Locals</a></li><li><a href="http://www.ecurrent.com/news/students/" >Students</a></li></ul></div></div></li>
                                                            <li><div class="row module-featuredpost mobile-hide-dropper"><div class="col-md-12 col-sm-12 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/feature/leaders-behind-a-cultural-rebirth-in-ypsilanti/" class="feature-thumb"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Ypsilanti is experiencing a cultural rebirth led by black artists, educators and activists" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/feature/leaders-behind-a-cultural-rebirth-in-ypsilanti/" rel="bookmark">Leaders Behind a Cultural Rebirth in Ypsilanti</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/cole-bednarski/" rel="author">By Cole Bednarski</a></span><span class="entry-date"><time class="entry-time" datetime="01 Feb 2017">01 Feb 2017</time></span></div></div></li>
                                                            <li><div class="row module-articlelist mobile-hide-dropper"><div class="col-md-12 col-sm-12 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" rel="bookmark">U.S. Education Secretary Betsy DeVos Advocates Return to Agrarian Society; Rich People Not Worried</a></h2><span class="entry-time">12 hours ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/remembering-black-history-in-ann-arbor/" rel="bookmark">Remembering Black History in Ann Arbor</a></h2><span class="entry-time">3 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/looking-for-new-love-and-cuddles-this-valentines-day/" rel="bookmark">Looking for new love and cuddles this Valentine&#8217;s Day?</a></h2><span class="entry-time">4 days ago</span></div></div></div></li>
                                                            <li><div class="row module-wysiwyg mobile-hide-dropper"><div class="col-md-12 col-sm-12 navcontent-opt"></div></div></li>
                                                    </ul>
                                            </li>
                                        <li class="mobile-nav-item ">
                        <a href="http://www.ecurrent.com/music/" class="has-submenu">Music<span class="caret"></span></a>
                                                <ul class="submenu-wrap sub-2 dropdown-menu">
                                                            <li><div class="row module-menu<br />
<b>Warning</b>:  in_array() expects parameter 2 to be array, string given in <b>/home/ecurrent/public_html/wp-content/themes/ecurrent/inc/infostream-conf.php</b> on line <b>1683</b><br />
"><div class="col-md-12 col-sm-12 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/music/" >The Latest</a></li><li><a href="http://www.ecurrent.com/music/features/" >Features</a></li><li><a href="http://www.ecurrent.com/music/notable/" >Notable</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/17/" >Shows</a></li></ul></div></div></li>
                                                            <li><div class="row module-featuredpost mobile-hide-dropper"><div class="col-md-12 col-sm-12 navfeatured-opt"><h2 class="navfeatured-title">Featured Post</h2><a href="http://www.ecurrent.com/music/a-spiny-unruly-journey/" class="feature-thumb"><img width="798" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Timothy Monger will be at The Ark on February 8." srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217.jpg 798w, http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217-768x433.jpg 768w" sizes="(max-width: 798px) 100vw, 798px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/music/a-spiny-unruly-journey/" rel="bookmark">A spiny, unruly journey</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/jeff-milo/" rel="author">By Jeff Milo</a></span><span class="entry-date"><time class="entry-time" datetime="01 Feb 2017">01 Feb 2017</time></span></div></div></li>
                                                            <li><div class="row module-articlelist mobile-hide-dropper"><div class="col-md-12 col-sm-12 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/" rel="bookmark">Five Pound Snap premiere new song “Lady Gets High”</a></h2><span class="entry-time">15 hours ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/checking-in-with-king-milo-and-louis-picasso/" rel="bookmark">Checking in with: King Milo and Louis Picasso</a></h2><span class="entry-time">2 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/bands-to-watch-in-2017-meshes-slug-love-bonzo-shuttershop/" rel="bookmark">Bands to Watch in 2017: Meshes, Slug Love, Bonzo, Shuttershop</a></h2><span class="entry-time">1 week ago</span></div></div></div></li>
                                                            <li><div class="row module-wysiwyg mobile-hide-dropper"><div class="col-md-12 col-sm-12 navcontent-opt"></div></div></li>
                                                    </ul>
                                            </li>
                                        <li class="mobile-nav-item ">
                        <a href="http://www.ecurrent.com/food-drink/" class="has-submenu">Food & Drink<span class="caret"></span></a>
                                                <ul class="submenu-wrap sub-3 dropdown-menu">
                                                            <li><div class="row module-menu<br />
<b>Warning</b>:  in_array() expects parameter 2 to be array, string given in <b>/home/ecurrent/public_html/wp-content/themes/ecurrent/inc/infostream-conf.php</b> on line <b>1683</b><br />
"><div class="col-md-12 col-sm-12 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/food-drink/" >The Latest</a></li><li><a href="http://www.ecurrent.com/food-drink/reviews/" >Reviews</a></li><li><a href="http://www.ecurrent.com/food-drink/drinks/" >Drinks</a></li><li><a href="http://www.ecurrent.com/food-drink/notable/" >Notable</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/12/" >Food Events</a></li></ul></div></div></li>
                                                            <li><div class="row module-featuredpost mobile-hide-dropper"><div class="col-md-12 col-sm-12 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" class="feature-thumb"><img width="800" height="500" src="http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Chef Raul Cob of Aventura in Ann Arbor" srcset="http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor-300x188.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor-768x480.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" rel="bookmark">New Aventura Chef Raúl Cob Enhances</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/adam-theisen/" rel="author">By Adam Theisen</a></span><span class="entry-date"><time class="entry-time" datetime="03 Feb 2017">03 Feb 2017</time></span></div></div></li>
                                                            <li><div class="row module-articlelist mobile-hide-dropper"><div class="col-md-12 col-sm-12 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" rel="bookmark">New Aventura Chef Raúl Cob Enhances</a></h2><span class="entry-time">7 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/this-month-in-food-and-drink-217/" rel="bookmark">This month in food and drink: 2/17</a></h2><span class="entry-time">1 week ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/2017-ann-arbor-restaurant-week-part-1/" rel="bookmark">2017 Ann Arbor Restaurant Week &#8211; Part 1</a></h2><span class="entry-time">1 month ago</span></div></div></div></li>
                                                            <li><div class="row module-wysiwyg mobile-hide-dropper"><div class="col-md-12 col-sm-12 navcontent-opt"></div></div></li>
                                                    </ul>
                                            </li>
                                        <li class="mobile-nav-item ">
                        <a href="http://www.ecurrent.com/arts-culture/" class="has-submenu">Arts & Culture<span class="caret"></span></a>
                                                <ul class="submenu-wrap sub-4 dropdown-menu">
                                                            <li><div class="row module-menu<br />
<b>Warning</b>:  in_array() expects parameter 2 to be array, string given in <b>/home/ecurrent/public_html/wp-content/themes/ecurrent/inc/infostream-conf.php</b> on line <b>1683</b><br />
"><div class="col-md-12 col-sm-12 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/arts-culture/" >The Latest</a></li><li><a href="http://www.ecurrent.com/arts-culture/visual-art/" >Visual Art</a></li><li><a href="http://www.ecurrent.com/arts-culture/film/" >Film</a></li><li><a href="http://www.ecurrent.com/arts-culture/theatre/" >Theatre</a></li><li><a href="http://www.ecurrent.com/arts-culture/lit/" >Lit</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/3/" >Art Events</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/19/" >Theatre Events</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/26/" >Film Events</a></li></ul></div></div></li>
                                                            <li><div class="row module-featuredpost mobile-hide-dropper"><div class="col-md-12 col-sm-12 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" class="feature-thumb"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Jonathan Barnbrook is probably best known for his design collaborations with David Bowie" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" rel="bookmark">Penny Stamps Speakers You Need to See</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/louis-meldman/" rel="author">By Louis Meldman</a></span><span class="entry-date"><time class="entry-time" datetime="06 Feb 2017">06 Feb 2017</time></span></div></div></li>
                                                            <li><div class="row module-articlelist mobile-hide-dropper"><div class="col-md-12 col-sm-12 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" rel="bookmark">Penny Stamps Speakers You Need to See</a></h2><span class="entry-time">4 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/art/be-mine-baby/" rel="bookmark">Be Mine, Baby!</a></h2><span class="entry-time">1 week ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/what-would-ann-arbor-look-like-with-a-sprawling-subway/" rel="bookmark">What would Ann Arbor look like with a sprawling subway?</a></h2><span class="entry-time">3 weeks ago</span></div></div></div></li>
                                                            <li><div class="row module-wysiwyg mobile-hide-dropper"><div class="col-md-12 col-sm-12 navcontent-opt"></div></div></li>
                                                    </ul>
                                            </li>
                                        <li class="mobile-nav-item ">
                        <a href="http://www.ecurrent.com/best-of/best-of-washtenaw-2016/" class="">Best Of</a>
                                            </li>
                                        <li class="mobile-nav-item ">
                        <a href="http://www.ecurrent.com/calendar/" class="">Calendar</a>
                                            </li>
                    </ul></nav></div>
            </div>
        </div>
        </div><!--.sosmedcontainer-->
    </div> <!--.header-top-->
	<header id="masthead" class="site-header" role="banner">
		<div class="header-main">
            <nav id="primary-navigation" class="navbar" role="navigation">
                <ul id="primary-mainmenu" class="menu nav navbar-nav sm sm-collapsible">                        <li class="primary-item sub-1 ">
                            <a href="http://www.ecurrent.com/news/">News</a>
                        </li>
                                                <li class="primary-item sub-2 ">
                            <a href="http://www.ecurrent.com/music/">Music</a>
                        </li>
                                                <li class="primary-item sub-3 ">
                            <a href="http://www.ecurrent.com/food-drink/">Food & Drink</a>
                        </li>
                                                <li class="primary-item sub-4 ">
                            <a href="http://www.ecurrent.com/arts-culture/">Arts & Culture</a>
                        </li>
                                                <li class="primary-item sub-5 ">
                            <a href="http://www.ecurrent.com/best-of/best-of-washtenaw-2016/">Best Of</a>
                        </li>
                                                <li class="primary-item sub-6 last-item">
                            <a href="http://www.ecurrent.com/calendar/">Calendar</a>
                        </li>
                        </ul>			</nav>
        </div>
	</header><!-- #masthead -->
    <div class="subwrap-secondnav" id="second-subnav">
        <div class="sub-secondnav">
            <div class="sub-wrap"><div class="sub-ov"></div>                        <div id="sub-1" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 vertical-line col-sm-3 vertical-line navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/news/" >The Latest</a></li><li><a href="http://www.ecurrent.com/news/business/" >Business</a></li><li><a href="http://www.ecurrent.com/news/environment/" >Enviroment</a></li><li><a href="http://www.ecurrent.com/news/cannabis/" >Cannabis</a></li><li><a href="http://www.ecurrent.com/news/locals/" >Locals</a></li><li><a href="http://www.ecurrent.com/news/students/" >Students</a></li></ul></div>                                                                    <div class="col-md-3 vertical-line col-sm-3 vertical-line navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/feature/leaders-behind-a-cultural-rebirth-in-ypsilanti/" class="feature-thumb"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Ypsilanti is experiencing a cultural rebirth led by black artists, educators and activists" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/feature/leaders-behind-a-cultural-rebirth-in-ypsilanti/" rel="bookmark">Leaders Behind a Cultural Rebirth in Ypsilanti</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/cole-bednarski/" rel="author">By Cole Bednarski</a></span><span class="entry-date"><time class="entry-time" datetime="01 Feb 2017">01 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" rel="bookmark">U.S. Education Secretary Betsy DeVos Advocates Return to Agrarian Society; Rich People Not Worried</a></h2><span class="entry-time">12 hours ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/remembering-black-history-in-ann-arbor/" rel="bookmark">Remembering Black History in Ann Arbor</a></h2><span class="entry-time">3 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/looking-for-new-love-and-cuddles-this-valentines-day/" rel="bookmark">Looking for new love and cuddles this Valentine&#8217;s Day?</a></h2><span class="entry-time">4 days ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-1-->
                                                <div id="sub-2" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 col-sm-3 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/music/" >The Latest</a></li><li><a href="http://www.ecurrent.com/music/features/" >Features</a></li><li><a href="http://www.ecurrent.com/music/notable/" >Notable</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/17/" >Shows</a></li></ul></div>                                                                    <div class="col-md-3 col-sm-3 navfeatured-opt"><h2 class="navfeatured-title">Featured Post</h2><a href="http://www.ecurrent.com/music/a-spiny-unruly-journey/" class="feature-thumb"><img width="798" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Timothy Monger will be at The Ark on February 8." srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217.jpg 798w, http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217-768x433.jpg 768w" sizes="(max-width: 798px) 100vw, 798px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/music/a-spiny-unruly-journey/" rel="bookmark">A spiny, unruly journey</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/jeff-milo/" rel="author">By Jeff Milo</a></span><span class="entry-date"><time class="entry-time" datetime="01 Feb 2017">01 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/" rel="bookmark">Five Pound Snap premiere new song “Lady Gets High”</a></h2><span class="entry-time">15 hours ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/checking-in-with-king-milo-and-louis-picasso/" rel="bookmark">Checking in with: King Milo and Louis Picasso</a></h2><span class="entry-time">2 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/bands-to-watch-in-2017-meshes-slug-love-bonzo-shuttershop/" rel="bookmark">Bands to Watch in 2017: Meshes, Slug Love, Bonzo, Shuttershop</a></h2><span class="entry-time">1 week ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-2-->
                                                <div id="sub-3" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 col-sm-3 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/food-drink/" >The Latest</a></li><li><a href="http://www.ecurrent.com/food-drink/reviews/" >Reviews</a></li><li><a href="http://www.ecurrent.com/food-drink/drinks/" >Drinks</a></li><li><a href="http://www.ecurrent.com/food-drink/notable/" >Notable</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/12/" >Food Events</a></li></ul></div>                                                                    <div class="col-md-3 col-sm-3 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" class="feature-thumb"><img width="800" height="500" src="http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Chef Raul Cob of Aventura in Ann Arbor" srcset="http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor-300x188.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor-768x480.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" rel="bookmark">New Aventura Chef Raúl Cob Enhances</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/adam-theisen/" rel="author">By Adam Theisen</a></span><span class="entry-date"><time class="entry-time" datetime="03 Feb 2017">03 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" rel="bookmark">New Aventura Chef Raúl Cob Enhances</a></h2><span class="entry-time">7 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/this-month-in-food-and-drink-217/" rel="bookmark">This month in food and drink: 2/17</a></h2><span class="entry-time">1 week ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/2017-ann-arbor-restaurant-week-part-1/" rel="bookmark">2017 Ann Arbor Restaurant Week &#8211; Part 1</a></h2><span class="entry-time">1 month ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-3-->
                                                <div id="sub-4" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 col-sm-3 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/arts-culture/" >The Latest</a></li><li><a href="http://www.ecurrent.com/arts-culture/visual-art/" >Visual Art</a></li><li><a href="http://www.ecurrent.com/arts-culture/film/" >Film</a></li><li><a href="http://www.ecurrent.com/arts-culture/theatre/" >Theatre</a></li><li><a href="http://www.ecurrent.com/arts-culture/lit/" >Lit</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/3/" >Art Events</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/19/" >Theatre Events</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/26/" >Film Events</a></li></ul></div>                                                                    <div class="col-md-3 col-sm-3 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" class="feature-thumb"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Jonathan Barnbrook is probably best known for his design collaborations with David Bowie" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" rel="bookmark">Penny Stamps Speakers You Need to See</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/louis-meldman/" rel="author">By Louis Meldman</a></span><span class="entry-date"><time class="entry-time" datetime="06 Feb 2017">06 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" rel="bookmark">Penny Stamps Speakers You Need to See</a></h2><span class="entry-time">4 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/art/be-mine-baby/" rel="bookmark">Be Mine, Baby!</a></h2><span class="entry-time">1 week ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/what-would-ann-arbor-look-like-with-a-sprawling-subway/" rel="bookmark">What would Ann Arbor look like with a sprawling subway?</a></h2><span class="entry-time">3 weeks ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-4-->
                        </div>
        </div> <!--.sub-secondnav-->
    </div> <!--.sub-secondnav-->
    <div class="pencil-ads">
            <div class="pencil-mobile mobile-ads">
        <a href="" target="_blank"></a>
        </div><!--.pencil-mobile-->
    </div><!--.pencil-ads-->
	
	<div class="leaderboard">
	<div class="desktop"><script type='text/javascript'><!--// <![CDATA[
    /* [id19] Current - 728x90 - Leaderboard */
    OA_show(19);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=604409f'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=19&amp;n=604409f' /></a></noscript></div>			<div class="mobile-ads">
			<div class="leaderboard-mobile"><script type='text/javascript'><!--// <![CDATA[
    /* [id47] Current - MOBILE - 320x50 - Leaderboard */
    OA_show(47);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=1f3082c'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=47&amp;n=1f3082c' /></a></noscript></div>		 </div>
		</div>

	<div id="main" class="site-main">	<div class="row row-eq-height"><div id="primary" class="content-area col-md-8">
		<div id="content" class="site-content" role="main">
			
<article id="post-25547" class="post-25547 post type-post status-publish format-standard has-post-thumbnail hentry category-music tag-music tag-music-wwup tag-online">

	<header class="entry-header">
				<h1 class="entry-title">Five Pound Snap premiere new song “Lady Gets High”</h1><div id="postdata"><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/jeff-milo/" rel="author">By Jeff Milo</a></span></span>.  February 9, 2017.</div><div class="post-featureimg"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/five-pound-snap-pic-by-megan-lacroix.jpg" class="attachment-full size-full wp-post-image" alt="Photo: Megan LaCroix" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/five-pound-snap-pic-by-megan-lacroix.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/five-pound-snap-pic-by-megan-lacroix-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/five-pound-snap-pic-by-megan-lacroix-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></div>Photo: Megan LaCroix
		<div class="entry-meta">
			<span class="byline"><span class="author vcard">by <a class="url fn n" href="http://www.ecurrent.com/author/jeff-milo/" rel="author">Jeff Milo</a></span></span> <span class="entry-date"><a href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/" rel="bookmark"><time class="entry-date" datetime="2017-02-09T15:37:32+00:00">February 9, 2017</time></a></span>			<span class="comments-link"><a href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/#respond"><span class="dsq-postid" data-dsqidentifier="25547 http://www.ecurrent.com/?p=25547">Leave a comment</span></a></span>
					</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

		<div class="entry-content">
		<div class='mailmunch-forms-before-post' style='display: none !important;'></div><p><a href="https://fivepoundsnap.bandcamp.com/">Five Pound Snap</a> are a four-piece out of Detroit that blend the grit, sweat, and spilled-out strummers of keyed-up rock ‘n’ roll with smoothness of jazz and the attitude of funk. Some bands are throttle-pushers, some are groove merchants, some are mood-molders, Five Pound Snap is all of that, and even something else that we haven’t quite put our finger on…</p>
<p><b>Five Pound Snap ~ “Lady Gets High” </b></p>
<p><iframe src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/306410747&amp;color=ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false" width="100%" height="166" frameborder="no" scrolling="no"></iframe><br />
“Lady Gets High” is a single from their forthcoming full length album <i>White Birch Lakes. </i>You can see the band perform <a href="https://www.facebook.com/events/1230077313739733/">this Friday night</a> over in Ferndale at the Loving Touch, with <a href="https://virginiavioletandtherays.bandcamp.com/">Virginia Violet and the Rays</a>, and <a href="https://ampeople.bandcamp.com/">AM People.</a></p>
<p>This song opens up with the tight hooks of post-millennial indie-rock, the cluster-clap of 60’s garage and the throaty howl of psychedelic-blues incantations. What continues to jut and juke its way with urgent riffs and cavalier stairwell-descending swiftness segues with subtlety and smoothness after the 2nd chorus, just as those drums, keyboard and guitars are swelling into a coiled busyness of harmonic tension, till the levee breaks and it spills its way in to a bridge where the saxophone shines, soars, splays and scintillates.</p>
<p>While you’re here, check out Five Pound Snap’s first single from <i>White Birch Lakes </i><a href="https://www.facebook.com/HuffingtonPost/">here</a>.</p><div class='mailmunch-forms-in-post-middle' style='display: none !important;'></div>
<p><a href="https://www.facebook.com/events/239557943140256/">After this Friday’s show</a> at the Loving Touch, the band is going to be hitting the road, warming themselves up for the official album release party, later in March.  This is one of those jump-on-the-bandwagon-now-while-you-can- kind of moments…because if <a href="https://www.youtube.com/watch?v=5jg4_iZTqcw&amp;feature=youtu.be">this video</a> is any indication, their collective engines are revved up; ready for the long ride.</p>
<p>More info:</p>
<p><a href="https://www.facebook.com/fivepoundsnap">https://www.facebook.com/fivepoundsnap</a></p>
<p><a href="https://fivepoundsnap.bandcamp.com/">https://fivepoundsnap.bandcamp.com/</a></p>
<div class='mailmunch-forms-after-post' style='display: none !important;'></div>	</div><!-- .entry-content -->
	
	<footer class="entry-meta"><span class="tag-links"><a href="http://www.ecurrent.com/tag/music/" rel="tag">Music</a><a href="http://www.ecurrent.com/tag/music-wwup/" rel="tag">music - wwup</a><a href="http://www.ecurrent.com/tag/online/" rel="tag">Online</a></span></footer></article><!-- #post-## -->
	<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<a href="http://www.ecurrent.com/music/checking-in-with-king-milo-and-louis-picasso/" rel="prev"><span class="meta-nav">&lt; Previous Post</span></a><a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" rel="next"><span class="meta-nav">Next Post &gt;</span></a>            <div class="clearfix"></div>
		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	<div class="et_social_icons_small"><div class="et_social_inline et_social_mobile_on inline">
                <div class="et_social_networks et_social_4col et_social_simple et_social_rectangle et_social_left et_social_no_animation et_social_outer_dark">
                    
                    <ul class="et_social_icons_container"><li class="et_social_facebook"><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.ecurrent.com%2Fmusic%2Ffive-pound-snap-premiere-new-song-lady-gets-high%2F&#038;t=Five%20Pound%20Snap%20premiere%20new%20song%20%E2%80%9CLady%20Gets%20High%E2%80%9D" class="et_social_share" rel="nofollow" data-social_name="facebook" data-post_id="25547" data-social_type="share"><i class="et_social_icon et_social_icon_facebook"></i><span class="et_social_overlay"></span></a></li><li class="et_social_twitter"><a href="http://twitter.com/home?status=Five%20Pound%20Snap%20premiere%20new%20song%20%E2%80%9CLady%20Gets%20High%E2%80%9D%20http%3A%2F%2Fwww.ecurrent.com%2Fmusic%2Ffive-pound-snap-premiere-new-song-lady-gets-high%2F" class="et_social_share" rel="nofollow" data-social_name="twitter" data-post_id="25547" data-social_type="share"><i class="et_social_icon et_social_icon_twitter"></i><span class="et_social_overlay"></span></a></li><li class="et_social_googleplus"><a href="https://plus.google.com/share?url=http%3A%2F%2Fwww.ecurrent.com%2Fmusic%2Ffive-pound-snap-premiere-new-song-lady-gets-high%2F&#038;t=Five%20Pound%20Snap%20premiere%20new%20song%20%E2%80%9CLady%20Gets%20High%E2%80%9D" class="et_social_share" rel="nofollow" data-social_name="googleplus" data-post_id="25547" data-social_type="share"><i class="et_social_icon et_social_icon_googleplus"></i><span class="et_social_overlay"></span></a></li><li class="et_social_pinterest"><a href="http://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.ecurrent.com%2Fmusic%2Ffive-pound-snap-premiere-new-song-lady-gets-high%2F&#038;media=&#038;description=Five%20Pound%20Snap%20premiere%20new%20song%20%E2%80%9CLady%20Gets%20High%E2%80%9D" class="et_social_share_pinterest" rel="nofollow" data-social_name="pinterest" data-post_id="25547" data-social_type="share"><i class="et_social_icon et_social_icon_pinterest"></i><span class="et_social_overlay"></span></a></li></ul>
                </div>
            </div></div>
<div id="disqus_thread">
    </div>

                        <article class="pagesection-1">
                            <div class="entry-content">
                                <div class="module-container  has-bg-color show-desktop-module  show-mobile-module ">
            <div class="row section-line grid">				<header class="section-header"><h2 class="entry-title">Trending</h2></header>                            <div class="module-article col-md-6"><div class="grid-wrap grip-row">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2017/02/DeVos-Dunce-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="Betsy DeVos Dunce" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" rel="bookmark">U.S. Education Secretary Betsy DeVos Advocates Return to Agrarian Society; Rich People Not Worried</a></h2>                                <span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/sonny-forrest/" rel="author">By Sonny Forrest</a></span></span><span class="entry-date">February 9, 2017</span><p>The new billionaire Secretary of Education and noted &#8220;school choice&#8221; proponent Betsy DeVos said during a news conference that she’s open to restoring America’s pre-20th Century agrarian society </p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                                                                                <div class="module-article col-md-6"><div class="grid-wrap grip-row">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/arts-culture/local-plays-for-every-valentines-day/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2017/02/ann-arbor-valentines-theatre-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="ann-arbor-valentines-theatre" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/arts-culture/local-plays-for-every-valentines-day/" rel="bookmark">Local plays for every Valentine&#8217;s Day</a></h2>                                <span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/sarah-matthews/" rel="author">By Sarah Matthews</a></span></span><span class="entry-date">February 6, 2017</span><p>Love, Loss, and Everything Inbetween</p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                            </div><!--.grid--><div class="row section-line grid">                                                    <div class="module-article col-md-6"><div class="grid-wrap grip-row">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/news/remembering-black-history-in-ann-arbor/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2017/02/ann-arbor-black-history-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="Ann Arbor has been on the progressive side of history for well over a century" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/news/remembering-black-history-in-ann-arbor/" rel="bookmark">Remembering Black History in Ann Arbor</a></h2>                                <span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/adam-theisen/" rel="author">By Adam Theisen</a></span></span><span class="entry-date">February 6, 2017</span><p>Preserving memories while inspiring new ones</p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                                                                                <div class="module-article col-md-6 hide-mobile-post"><div class="grid-wrap grip-row">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/literature/true-life-reads-for-february/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2017/02/ann-arbor-valentines-book-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="ann-arbor-valentines-book" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/literature/true-life-reads-for-february/" rel="bookmark">True Life Reads for February</a></h2>                                <span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/sarah-matthews/" rel="author">By Sarah Matthews</a></span></span><span class="entry-date">February 6, 2017</span><p>My Non-Fiction Valentine</p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                            </div><!--.grid-->                        </div><!--.grid-container-->                            </div><!-- .entry-content -->
                        </article><!-- #post-## -->
                        		</div><!-- #content -->
	</div><!-- #primary -->
    <div class="section-sidebar col-md-4">
    <div id="secondary">
	    
	    <div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
		    <aside class="widget pagesection-1 contentblock"><div class="module-container  default-bg-color show-desktop-module  show-mobile-module ">
            <div class="section-line contentblock">                                        <div class="desktop-content"><p><script type="text/javascript">// <![CDATA[
/* [id30] Current - 300x600 */ OA_show(30); // ]]&gt;
// ]]&gt;</script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=a472f36'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=30&amp;n=a472f36' /></a></noscript></p>
</div><!--.desktop-content-->
                                                            <div class="mobile-content"><p><script type="text/javascript">// <![CDATA[
/* [id20] Current - 300x250 */ OA_show(20); // ]]&gt;
// ]]&gt;</script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=5056e21'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=20&amp;n=5056e21' /></a></noscript></p>
</div><!--.desktop-content-->
                                        </div><!--.grid-container--></aside><aside class="widget pagesection-2 horizontalscroll"><div class="module-container  default-bg-color show-desktop-module  show-mobile-module ">
            <div class="section-line horizontalscroll">				<header class="section-header"><h2 class="entry-title">Guides</h2></header><div class="carousel-module"><div class="carousel-ecurrent-module cycle-slideshow"
                        data-cycle-fx="carousel"
                        data-cycle-speed="500" 
                        data-cycle-timeout=0
                        data-cycle-slides="div.module-article" 
                        data-cycle-prev=".prevarticles-iSmWk" 
                        data-cycle-next=".nextarticles-iSmWk" 
                        data-cycle-pause-on-hover="true">                            <div class="module-article normal-module"><div class="grid-wrap ">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/health/2017-health-and-wellness/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2017/01/health-wellness-current-1-17-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="health-wellness-current-1-17" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/health/2017-health-and-wellness/" rel="bookmark">2017 Health and Wellness</a></h2>                                <p>The local pros highlighted in this guide will make you happy, fit and ready to take on anything this year throws at you.</p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                                                                                <div class="module-article normal-module"><div class="grid-wrap ">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/features/2016-holiday-gift-guide/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2016/11/Gift-guide-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="Gift-guide" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/features/2016-holiday-gift-guide/" rel="bookmark">2016 Holiday Gift Guide</a></h2>                                <p>Washtenaw County has many independently owned, unique stores for finding that perfect present. We’ve got the details on deals, gift ideas and holiday treats for everyone in the family— consider it our early gift to you. Happy holidays! A2 Yoga 2030 Commerce Blvd. 734-216-4006 | a2yoga.net A2 Yoga has been part of the Ann Arbor community </p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                                                                                <div class="module-article normal-module"><div class="grid-wrap ">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/arts-culture/guide-to-the-arts-2016/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2016/10/guidetoarts2-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="guidetoarts2" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/arts-culture/guide-to-the-arts-2016/" rel="bookmark">Guide to the Arts 2016</a></h2>                                <p>Current Magazine covers the best art and entertainment from now until the end of the year. Here is what’s happening on the stage, screen and so much more! Stage Mary Poppins Encore Musical Theatre concludes their year with a performance of the Broadway music based on the books and classic movie. 11/25 &#8211; 12/23 | theencoretheatre.org </p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                                                                                <div class="module-article normal-module"><div class="grid-wrap ">
                                                                <div class="normal-grid">
                                <a href="http://www.ecurrent.com/arts-culture/2016-wedding-guide-happily-ever-after/" class="article-thumb">
                                <img width="300" height="163" src="http://www.ecurrent.com/wp-content/uploads/2016/10/weddingguidelogo-300x163.jpg" class="attachment-small-grid size-small-grid wp-post-image" alt="weddingguidelogo" />                                                                </a>
                                </div>
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/arts-culture/2016-wedding-guide-happily-ever-after/" rel="bookmark">2016 Wedding Guide: Happily Ever After</a></h2>                                <p>Planning for that big day can be difficult, Current&#8217;s Wedding Guide is here to help you find everything from caterers to jewelers for the big day. </p>
</div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                                                    </div><!--.slides-->
        <div class="floating-outer">
            <div class="wrap-controller">
                <a class="navcontroller prev prevarticles-iSmWk" href="javascript:;"></a>
                <a class="navcontroller next nextarticles-iSmWk" href="javascript:;"></a>
            </div>
        </div> <!--.floating-outer-->
        </div><!--.carousel-module--></div><!--.grid-container--></aside><aside class="widget pagesection-3 contentblock"><div class="module-container  default-bg-color show-desktop-module  show-mobile-module ">
            <div class="section-line contentblock">                                        <div class="desktop-content"><p><script type="text/javascript">// <![CDATA[
/* [id41] Current - 300x250 - 2 */ OA_show(41); // ]]&gt;
// ]]&gt;</script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=f028cd0'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=41&amp;n=f028cd0' /></a></noscript></p>
</div><!--.desktop-content-->
                                                            <div class="mobile-content"><p><script type="text/javascript">// <![CDATA[
/* [id41] Current - 300x250 - 2 */ OA_show(41); // ]]&gt;
// ]]&gt;</script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=f028cd0'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=41&amp;n=f028cd0' /></a></noscript></p>
</div><!--.desktop-content-->
                                        </div><!--.grid-container--></aside><aside class="widget pagesection-4 basiclist"><div class="module-container  default-bg-color show-desktop-module  show-mobile-module ">
            <div class="section-line basiclist">				<header class="section-header"><h2 class="entry-title">News</h2></header>                            <div class="module-article "><div class="grid-wrap mobile-grip-row">
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" rel="bookmark">U.S. Education Secretary Betsy DeVos Advocates Return to Agrarian Society; Rich People Not Worried</a></h2>                                </div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                            </div><!--.basiclist--><div class="section-line basiclist 1">                                                    <div class="module-article "><div class="grid-wrap mobile-grip-row">
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/news/remembering-black-history-in-ann-arbor/" rel="bookmark">Remembering Black History in Ann Arbor</a></h2>                                </div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                            </div><!--.basiclist--><div class="section-line basiclist 2">                                                    <div class="module-article  hide-mobile-post"><div class="grid-wrap mobile-grip-row">
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/news/looking-for-new-love-and-cuddles-this-valentines-day/" rel="bookmark">Looking for new love and cuddles this Valentine&#8217;s Day?</a></h2>                                </div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                            </div><!--.basiclist--><div class="basiclist">                                                    <div class="module-article  hide-mobile-post"><div class="grid-wrap mobile-grip-row">
                                                                <div class="normal-grid">
                                <h2 class="section-title"><a href="http://www.ecurrent.com/news/lessons-learned-from-breast-cancer/" rel="bookmark">Lessons learned from breast cancer</a></h2>                                </div>
                            </div><!--.grid-wrap--></div><!--.module-article-->
                            </div><!--.basiclist-->                        </div><!--.grid-container--></aside><aside class="widget pagesection-5 contentblock"><div class="module-container  default-bg-color show-desktop-module  show-mobile-module ">
            <div class="section-line contentblock">                                        <div class="desktop-content"><p><center><!--/*
  *
  * Revive Adserver Javascript Tag
  * - Generated with Revive Adserver v3.1.0
  *
  */--></p>
<p><!--/*
  * The backup image section of this tag has been generated for use on a
  * non-SSL page. If this tag is to be placed on an SSL page, change the
  *   'http://mlivingnews.com/revive/www/delivery/...'
  * to
  *   'https://mlivingnews.com/revive/www/delivery/...'
  *
  * This noscript section of this tag only shows image banners. There
  * is no width or height in these banners, so if you want these tags to
  * allocate space for the ad before it shows, you will need to add this
  * information to the <img> tag.
  *
  * If you do not want to deal with the intricities of the noscript
  * section, delete the tag (from <noscript>... to </noscript>). On
  * average, the noscript tag is called from less than 1% of internet
  * users.
  */--></p>
<p><script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://mlivingnews.com/revive/www/delivery/ajs.php':'http://mlivingnews.com/revive/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=42");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&#038;context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]&gt;--></script><noscript><a href='http://mlivingnews.com/revive/www/delivery/ck.php?n=a15fc08c&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=42&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a15fc08c' border='0' alt='' /></a></noscript><br />
</center></p>
</div><!--.desktop-content-->
                                                            <div class="mobile-content"><p><center><!--/*
  *
  * Revive Adserver Javascript Tag
  * - Generated with Revive Adserver v3.1.0
  *
  */--></p>
<p><!--/*
  * The backup image section of this tag has been generated for use on a
  * non-SSL page. If this tag is to be placed on an SSL page, change the
  *   'http://mlivingnews.com/revive/www/delivery/...'
  * to
  *   'https://mlivingnews.com/revive/www/delivery/...'
  *
  * This noscript section of this tag only shows image banners. There
  * is no width or height in these banners, so if you want these tags to
  * allocate space for the ad before it shows, you will need to add this
  * information to the <img> tag.
  *
  * If you do not want to deal with the intricities of the noscript
  * section, delete the tag (from <noscript>... to </noscript>). On
  * average, the noscript tag is called from less than 1% of internet
  * users.
  */--></p>
<p><script type='text/javascript'><!--//<![CDATA[
   var m3_u = (location.protocol=='https:'?'https://mlivingnews.com/revive/www/delivery/ajs.php':'http://mlivingnews.com/revive/www/delivery/ajs.php');
   var m3_r = Math.floor(Math.random()*99999999999);
   if (!document.MAX_used) document.MAX_used = ',';
   document.write ("<scr"+"ipt type='text/javascript' src='"+m3_u);
   document.write ("?zoneid=42");
   document.write ('&amp;cb=' + m3_r);
   if (document.MAX_used != ',') document.write ("&amp;exclude=" + document.MAX_used);
   document.write (document.charset ? '&amp;charset='+document.charset : (document.characterSet ? '&amp;charset='+document.characterSet : ''));
   document.write ("&amp;loc=" + escape(window.location));
   if (document.referrer) document.write ("&amp;referer=" + escape(document.referrer));
   if (document.context) document.write ("&#038;context=" + escape(document.context));
   if (document.mmm_fo) document.write ("&amp;mmm_fo=1");
   document.write ("'><\/scr"+"ipt>");
//]]&gt;--></script><noscript><a href='http://mlivingnews.com/revive/www/delivery/ck.php?n=a15fc08c&amp;cb=INSERT_RANDOM_NUMBER_HERE' target='_blank'><img src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=42&amp;cb=INSERT_RANDOM_NUMBER_HERE&amp;n=a15fc08c' border='0' alt='' /></a></noscript><br />
</center></p>
</div><!--.desktop-content-->
                                        </div><!--.grid-container--></aside>	    </div><!-- #primary-sidebar -->
    </div><!-- #secondary -->
</div>    </div>
		</div><!-- #main -->

		<footer id="colophon" class="site-footer" role="contentinfo">
			<div class="site-info">
                <div class="row inset-row">
                    <div class="col-md-3 logo-container">
                        	<form method="get" id="searchform" action="http://www.ecurrent.com/">
		<input type="text" class="field" name="s" id="s" placeholder="Search" />
		<input type="submit" class="submit" name="submit" id="searchsubmit" value="&gt;" />
	</form>
                        <a href="http://www.ecurrent.com/" rel="home" class="footer-logo"><img src="http://www.ecurrent.com/wp-content/themes/ecurrent/images/footerlogo.png" alt="Current Magazine" width="113" height="72"></a>
                        <div class="social-network">
                             <a href="https://www.instagram.com/current_mag/" target="_blank" class="sosmed"><img width="18" height="18" src="http://www.ecurrent.com/wp-content/uploads/2016/05/instagram.png" class="attachment-full size-full" alt="instagram" /></a>
                             <a href="https://www.facebook.com/currentmagazine/" target="_blank" class="sosmed"><img width="9" height="18" src="http://www.ecurrent.com/wp-content/uploads/2016/05/facebook.png" class="attachment-full size-full" alt="facebook" /></a>
                             <a href="https://twitter.com/ecurrent" target="_blank" class="sosmed"><img width="19" height="17" src="http://www.ecurrent.com/wp-content/uploads/2016/05/twitter.png" class="attachment-full size-full" alt="twitter" /></a>
                                                    </div>
                    </div>
                    <div class="col-md-2 col-xs-6"><ul class="footer-menu odd">                                <li><a href="http://www.ecurrent.com/news/" >News</a></li>
                                                                <li><a href="http://www.ecurrent.com/music/" >Music</a></li>
                                                                <li><a href="http://www.ecurrent.com/food-drink/" >Food & Drink</a></li>
                                                                <li><a href="http://www.ecurrent.com/arts-culture/" >Arts & Culture</a></li>
                                                                <li><a href="http://www.ecurrent.com/best-of/" >Best Of</a></li>
                                                                <li><a href="http://www.ecurrent.com/calendar/" >Calendar</a></li>
                                </div></ul><div class="col-md-2 col-xs-6"><ul class="footer-menu even">                                <li><a href="http://www.ecurrent.com/contact/" >Contact</a></li>
                                                                <li><a href="http://www.ecurrent.com/advertise/" >Advertise</a></li>
                                                                <li><a href="http://www.ecurrent.com/employment/" >Employment</a></li>
                                                                <li><a href="http://www.ecurrent.com/privacy/" >Privacy</a></li>
                                                                <li><a href="http://www.ecurrent.com/archives/" >Archives</a></li>
                                                                <li><a href="http://www.ecurrent.com/our-other-publications/" >Our Other Publications</a></li>
                                </div></ul>                    <div class="col-md-5 footer-latest">
                        <div class="row">
                            <p><iframe src="http://static.issuu.com/widgets/shelf/index.html?folderId=f735bf0e-81fa-4d8c-bd37-0da178213579&amp;theme=theme2&amp;rows=1&amp;thumbSize=medium&amp;roundedCorners=false&amp;showTitle=true&amp;showAuthor=true&amp;shadow=true&amp;effect3d=true" width="100%" height="300" frameborder="0" marginwidth="0" marginheight="0" scrolling="no"></iframe></p>
                        </div>
                    </div>
                </div>
                <div class="inset-row leaderboard-footer">
                                    <div class="desktop">                        <script type='text/javascript'><!--// <![CDATA[
    /* [id43] Current - Footer - 728x90 */
    OA_show(43);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=9b6c5bf'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=43&amp;n=9b6c5bf' /></a></noscript>                    </div>
                    <div class="mobile mobile-ads">
                                            <div class="desktop"><script type='text/javascript'><!--// <![CDATA[
    /* [id46] Current - MOBILE - 320x50 - position 3 */
    OA_show(46);
// ]]> --></script><noscript><a target='_blank' href='http://mlivingnews.com/revive/www/delivery/ck.php?n=851f72d'><img border='0' alt='' src='http://mlivingnews.com/revive/www/delivery/avw.php?zoneid=46&amp;n=851f72d' /></a></noscript></div>                    </div>
                </div>
			</div><!-- .site-info -->
            <div class="row row-bottom inset-row">
                <div class="col-md-6 copyright">Copyright © 2016. All Rights Reserved.</div>
                <div class="col-md-6 infostream-logo"><a href="http://www.infostreamusa.com/" target="_blank" title="InfoStream Solutions">Website Design Toledo by InfoStream Solutions</a></div> <!--.infostream-logo--> 
            </div>
		</footer><!-- #colophon -->
        </div><!--.ecurrent-wrap-->
<div class="col-md-2 leaderboard-side right-leaderboard"><div class="leaderboard-ads">
            <div class="leaderboard-mobile mobile-ads">
            <a href="" target="_blank"></a>
        </div>
    </div><!--.leaderboard-ads--></div>
</div></div>
	</div><!-- #page -->
<div class="nav-stick"><div class="container"><div class="row">
    <div class="col-md-2"></div>
    <div class="col-md-8">
        <header class="site-header fixed-header" role="banner">
            <div class="header-main">
                <nav id="primary-navigation-stick" class="navbar" role="navigation">
                    <div class="row">
                        <div class="col-md-2 col-sm-2 stick-logo"><a class="stick-brand" href="http://www.ecurrent.com/" rel="home"><img width="138" height="30" src="http://www.ecurrent.com/wp-content/uploads/2016/05/current-small-white.png" class="attachment-full size-full" alt="current-small-white" /></a>
                        </div><div class="col-md-10 col-sm-10 menunav">
                            <ul id="primary-mainmenu-sticky" class="menu nav navbar-nav sm sm-collapsible">                        <li class="primary-item sub-1-sticky ">
                            <a href="http://www.ecurrent.com/news/">News</a>
                        </li>
                                                <li class="primary-item sub-2-sticky ">
                            <a href="http://www.ecurrent.com/music/">Music</a>
                        </li>
                                                <li class="primary-item sub-3-sticky ">
                            <a href="http://www.ecurrent.com/food-drink/">Food & Drink</a>
                        </li>
                                                <li class="primary-item sub-4-sticky ">
                            <a href="http://www.ecurrent.com/arts-culture/">Arts & Culture</a>
                        </li>
                                                <li class="primary-item sub-5-sticky ">
                            <a href="http://www.ecurrent.com/best-of/best-of-washtenaw-2016/">Best Of</a>
                        </li>
                                                <li class="primary-item sub-6-sticky last-item">
                            <a href="http://www.ecurrent.com/calendar/">Calendar</a>
                        </li>
                        </ul>                        </div>
                    </div>
                </nav>
            </div>
        </header><!-- #masthead -->
        <div class="subwrap-secondnav stickednav" id="second-subnav-stick">
            <div class="sub-secondnav">
                <div class="sub-wrap"><div class="sub-ov"></div>                        <div id="sub-1-sticky" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 vertical-line col-sm-3 vertical-line navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/news/" >The Latest</a></li><li><a href="http://www.ecurrent.com/news/business/" >Business</a></li><li><a href="http://www.ecurrent.com/news/environment/" >Enviroment</a></li><li><a href="http://www.ecurrent.com/news/cannabis/" >Cannabis</a></li><li><a href="http://www.ecurrent.com/news/locals/" >Locals</a></li><li><a href="http://www.ecurrent.com/news/students/" >Students</a></li></ul></div>                                                                    <div class="col-md-3 vertical-line col-sm-3 vertical-line navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/feature/leaders-behind-a-cultural-rebirth-in-ypsilanti/" class="feature-thumb"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Ypsilanti is experiencing a cultural rebirth led by black artists, educators and activists" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/ypsilanti-culture-2-17-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/feature/leaders-behind-a-cultural-rebirth-in-ypsilanti/" rel="bookmark">Leaders Behind a Cultural Rebirth in Ypsilanti</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/cole-bednarski/" rel="author">By Cole Bednarski</a></span><span class="entry-date"><time class="entry-time" datetime="01 Feb 2017">01 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/online/u-s-education-secretary-betsy-devos-advocates-return-to-agrarian-society-rich-people-not-worried/" rel="bookmark">U.S. Education Secretary Betsy DeVos Advocates Return to Agrarian Society; Rich People Not Worried</a></h2><span class="entry-time">12 hours ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/remembering-black-history-in-ann-arbor/" rel="bookmark">Remembering Black History in Ann Arbor</a></h2><span class="entry-time">3 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/looking-for-new-love-and-cuddles-this-valentines-day/" rel="bookmark">Looking for new love and cuddles this Valentine&#8217;s Day?</a></h2><span class="entry-time">4 days ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-1-->
                                                <div id="sub-2-sticky" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 col-sm-3 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/music/" >The Latest</a></li><li><a href="http://www.ecurrent.com/music/features/" >Features</a></li><li><a href="http://www.ecurrent.com/music/notable/" >Notable</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/17/" >Shows</a></li></ul></div>                                                                    <div class="col-md-3 col-sm-3 navfeatured-opt"><h2 class="navfeatured-title">Featured Post</h2><a href="http://www.ecurrent.com/music/a-spiny-unruly-journey/" class="feature-thumb"><img width="798" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Timothy Monger will be at The Ark on February 8." srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217.jpg 798w, http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/Music-Feature217-768x433.jpg 768w" sizes="(max-width: 798px) 100vw, 798px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/music/a-spiny-unruly-journey/" rel="bookmark">A spiny, unruly journey</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/jeff-milo/" rel="author">By Jeff Milo</a></span><span class="entry-date"><time class="entry-time" datetime="01 Feb 2017">01 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/" rel="bookmark">Five Pound Snap premiere new song “Lady Gets High”</a></h2><span class="entry-time">15 hours ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/checking-in-with-king-milo-and-louis-picasso/" rel="bookmark">Checking in with: King Milo and Louis Picasso</a></h2><span class="entry-time">2 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/music/bands-to-watch-in-2017-meshes-slug-love-bonzo-shuttershop/" rel="bookmark">Bands to Watch in 2017: Meshes, Slug Love, Bonzo, Shuttershop</a></h2><span class="entry-time">1 week ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-2-->
                                                <div id="sub-3-sticky" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 col-sm-3 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/food-drink/" >The Latest</a></li><li><a href="http://www.ecurrent.com/food-drink/reviews/" >Reviews</a></li><li><a href="http://www.ecurrent.com/food-drink/drinks/" >Drinks</a></li><li><a href="http://www.ecurrent.com/food-drink/notable/" >Notable</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/12/" >Food Events</a></li></ul></div>                                                                    <div class="col-md-3 col-sm-3 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" class="feature-thumb"><img width="800" height="500" src="http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Chef Raul Cob of Aventura in Ann Arbor" srcset="http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor-300x188.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/01/Raul_Aventura-ann-arbor-768x480.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" rel="bookmark">New Aventura Chef Raúl Cob Enhances</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/adam-theisen/" rel="author">By Adam Theisen</a></span><span class="entry-date"><time class="entry-time" datetime="03 Feb 2017">03 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/new-aventura-chef-raul-cob-enhances/" rel="bookmark">New Aventura Chef Raúl Cob Enhances</a></h2><span class="entry-time">7 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/this-month-in-food-and-drink-217/" rel="bookmark">This month in food and drink: 2/17</a></h2><span class="entry-time">1 week ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/food/2017-ann-arbor-restaurant-week-part-1/" rel="bookmark">2017 Ann Arbor Restaurant Week &#8211; Part 1</a></h2><span class="entry-time">1 month ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-3-->
                                                <div id="sub-4-sticky" class="subsecond-item">
                            <div class="submenu-wrap row row-eq-height">
                                                                    <div class="col-md-3 col-sm-3 navmenu-opt"><ul class="menus-opt"><li><a href="http://www.ecurrent.com/arts-culture/" >The Latest</a></li><li><a href="http://www.ecurrent.com/arts-culture/visual-art/" >Visual Art</a></li><li><a href="http://www.ecurrent.com/arts-culture/film/" >Film</a></li><li><a href="http://www.ecurrent.com/arts-culture/theatre/" >Theatre</a></li><li><a href="http://www.ecurrent.com/arts-culture/lit/" >Lit</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/3/" >Art Events</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/19/" >Theatre Events</a></li><li><a href="http://www.ecurrent.com/Calendar/#!/show/26/" >Film Events</a></li></ul></div>                                                                    <div class="col-md-3 col-sm-3 navfeatured-opt"><h2 class="navfeatured-title">Featured</h2><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" class="feature-thumb"><img width="800" height="450" src="http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Jonathan Barnbrook is probably best known for his design collaborations with David Bowie" srcset="http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover.jpg 800w, http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover-300x169.jpg 300w, http://www.ecurrent.com/wp-content/uploads/2017/02/Stamps-Johnathan-barnbrook-Bowie-cover-768x432.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a><h2 class="entry-title"><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" rel="bookmark">Penny Stamps Speakers You Need to See</a></h2><span class="author vcard"><a class="url fn n" href="http://www.ecurrent.com/author/louis-meldman/" rel="author">By Louis Meldman</a></span><span class="entry-date"><time class="entry-time" datetime="06 Feb 2017">06 Feb 2017</time></span></div>                                                                    <div class="col-md-3 col-sm-3 navarticle-opt"><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/art/penny-stamps-speakers-you-need-to-see/" rel="bookmark">Penny Stamps Speakers You Need to See</a></h2><span class="entry-time">4 days ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/art/be-mine-baby/" rel="bookmark">Be Mine, Baby!</a></h2><span class="entry-time">1 week ago</span></div><div class="nav-article"><h2 class="entry-title"><a href="http://www.ecurrent.com/news/what-would-ann-arbor-look-like-with-a-sprawling-subway/" rel="bookmark">What would Ann Arbor look like with a sprawling subway?</a></h2><span class="entry-time">3 weeks ago</span></div></div>                                                                    <div class="col-md-3 col-sm-3 navcontent-opt"></div>                                                            </div>
                        </div> <!--#sub-4-->
                        </div>
            </div> <!--.sub-secondnav-->
        </div> <!--.sub-secondnav-->
    </div>
    <div class="col-md-2"></div>
</div></div></div><!--.nav-stick-->
	<div class="et_social_pin_images_outer">
					<div class="et_social_pinterest_window">
						<div class="et_social_modal_header"><h3>Pin It on Pinterest</h3><span class="et_social_close"></span></div>
						<div class="et_social_pin_images" data-permalink="http://www.ecurrent.com/music/five-pound-snap-premiere-new-song-lady-gets-high/" data-title="Five Pound Snap premiere new song “Lady Gets High”" data-post_id="25547"></div>
					</div>
				</div><script type='text/javascript' src='http://www.ecurrent.com/wp-content/plugins/monarch/js/ouibounce.js?ver=1.1.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var monarchSettings = {"ajaxurl":"http:\/\/www.ecurrent.com\/wp-admin\/admin-ajax.php","pageurl":"http:\/\/www.ecurrent.com\/music\/five-pound-snap-premiere-new-song-lady-gets-high\/","stats_nonce":"c252facf52","share_counts":"277ed450c6","follow_counts":"5721fa9dfb","total_counts":"103df0652f","media_single":"ee71d2fdd0","media_total":"c863562985","no_img_message":"No images available for sharing on this page"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/plugins/monarch/js/custom.js?ver=1.1.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-includes/js/comment-reply.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/functions.js?ver=20140616'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-includes/js/wp-embed.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery.parallax-1.1.3.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/isotope.pkgd.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/bootstrap.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery.smartmenus.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery.smartmenus.bootstrap.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery.easing.1.3.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery.cycle2.min.js?ver=4.5.2'></script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/themes/ecurrent/js/jquery.cycle2.carousel.min.js?ver=4.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.5.2","language":""},"disqusIdentifier":"25547 http:\/\/www.ecurrent.com\/?p=25547","disqusShortname":"current-magazine","disqusTitle":"Five Pound Snap premiere new song \u201cLady Gets High\u201d","disqusUrl":"http:\/\/www.ecurrent.com\/music\/five-pound-snap-premiere-new-song-lady-gets-high\/","options":{"manualSync":false},"postId":"25547"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"current-magazine"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ecurrent.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.5.2'></script>
<script type="text/javascript">/* Run FooBox FREE (v1.1.11) */
(function( FOOBOX, $, undefined ) {
  FOOBOX.o = {wordpress: { enabled: true }, excludes:'.fbx-link,.nofoobox,.nolightbox,a[href*="pinterest.com/pin/create/button/"]', affiliate : { enabled: false }, error: "Could not load the item"};
  FOOBOX.init = function() {
    $(".fbx-link").removeClass("fbx-link");
    $(".gallery, .wp-caption, a:has(img[class*=wp-image-]), .foobox").foobox(FOOBOX.o);
  };
}( window.FOOBOX = window.FOOBOX || {}, FooBox.$ ));

FooBox.ready(function() {

  jQuery("body").append("<span style=\"font-family:'foobox'; color:transparent; position:absolute; top:-1000em;\">f</span>");
  FOOBOX.init();

});
</script></body>
</html>
<!-- Dynamic page generated in 1.095 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2017-02-10 07:05:06 -->

<!-- super cache -->